Please Wait...
BYOD Powered by Cloudpath Networks
University of MN Duluth uses XpressConnect by Cloudpath Networks to automate WPA2 across a wide variety of device types and ownership.  Background curve top   Background curve top
Background curve side
banner image
Welcome To The
University of MN Duluth Network
XpressConnect needs to be loaded to access the secure network.
To access the secure network, follow the instructions below based on your computer's operating system.

Microsoft Windows

  • Download this file: NetworkWizardLoader.exe
  • When prompted, save the file to your desktop. Some browsers will do this automatically.
    Go to your desktop and open the file "NetworkWizardLoader.exe".
    Note: If you are using Windows XP, you must have at least Service Pack 2 installed. If you do not have Service Pack 2 installed, please run Windows Update to receive Service Pack 2. If you are unsure, run XpressConnect and it will prompt you if Service Pack 2 is not installed.
    If you prefer, you may select one of the following loading mechanisms: Java Applet or ActiveX.

Mac OS X Lion & Mountain Lion

Mac OS X Snow Leopard, Leopard & Tiger

  • XpressConnect was unable to start itself using Java. You need to select one of the options below to manually start the application :
  • Safari Users: Click here to manually download the application. Next, locate XpressConnect in the Downloads window, hold down the Control key, click XpressConnect and select Open. You will be informed that XpressConnect is an application downloaded from the Internet and asked if you would like to open it. Click Open.

  • Firefox Users: Click here to manually download the application. When prompted, select to open the file with StuffIt Expander and click "Ok". Next, locate the Downloads window, hold down the Control key, click XpressConnect.app.zip, and select Show in Finder. Double-click on XpressConnect. You will be informed that XpressConnect is an application downloaded from the Internet and asked if you would like to open it. Click Open.


  • If the application still does not load, Java may have been either uninstalled from your computer or disabled. To reinstall, visit http://developer.apple.com/java/download.
    If you would like to try the Java version again, please click here to load XpressConnect.

Ubuntu

  1. Download this file: XpressConnect-Linux.tar and select to Open with Archive Manager.
  2. After the download completes, the Archive Manager window will display. Within Archive Manager, click the Extract button.
  3. When prompted, select to save the file to the Desktop and click Extract.
  4. After the file is extracted, go to the Desktop and double-click on the file XpressConnect-DoubleClickToRun.
  5. When prompted, click the Run button.
  6. If you prefer and have Java installed, you may load XpressConnect via a Java Applet by clicking here.

Apple iPhone, iPad, & iPod Touch

    After clicking the link above, you will be walked through installing a configuration profile for iPhone, iPad, or iPod Touch.
    If using an iPhone or iPod Touch, version 2 or greater is required. If you do not have version 2 or greater, you will need to connect your iPhone, iPad, or iPod Touch to your computer and run iTunes to update the firmware. All versions of iPad are supported.

Android Devices

  • If you do not already have the XpressConnect app installed, please select an install option and click the 'Install' button.
  • Currently, only Android versions 2.1 and newer are supported. If you have an Android device with an older Android version you will need to configure it manually.

Other Operating Systems

    Your operating system is not currently supported for automated configuration. Please contact the support desk for manual configuration instructions.
Background curve side image
Background curve lower image   Background curve lower image