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	1. Download or create a background image for your page.  Save an optimized version (.jpg, .gif, .png format) in the “assets” folder of your project’s or exercise’s “local root” folder.  

	
	A. See in-class directions for specifics of folder names, image locations, etc.  



	2. In Dreamweaver, open and save a new, blank HTML page as “index.html” in the project’s local root folder.    

	
	A.  File > New  > Blank Page > HTML > none (under “Layout)



	3. Insert the background image onto the page, note the dimensions of the image, and wrap the image in a new div called “container.”  

	
	A.  Be sure to import your “www” site
B. Drag the image file from the “assets” folder into the document screen
C. Click on the image and write down the W and H values that appear in the Properties Panel at the bottom. 
[bookmark: _GoBack]D. With the image still selected, choose Insert > Layout Objects > Div Tag
E. From the Insert Div Tag window, be sure “Wrap around selection” is chosen for “Insert” and click OK.  



	4. Create an ID (a set of CSS rules starting with #) titled “container” for the container div which makes the div the same height and width as the image and which centers the div on the page.  Apply those rules to the div itself.  

	
	A.  In the CSS Styles panel on the upper right, click the “New Style” icon [image: ]
B.  In the “New CSS Rule” window, choose “ID” under “Selector Type”
C.  Under “Selector Name,” type “container”
D.  Under “Rule Definition,” decide if you want an inline style (this page only) or an external style sheet.  For this exercise (since we’re only producing one page), choose “This document only”  
E. In the “CSS Rule definition for #container” window, choose “Box” from the 
“Category” menu on the left
F. Under “Box,” enter the width and height measurements of the background image to make the div the same dimensions as the image.  
G. Under “Margin,” uncheck the “Same for all” box.  
H. Set both “Right” and “Left” values to “auto” to center the div.  
I. Click “OK” to close the “CSS Rule definition…” window
J.  In the document, click on the image, look in the “Tag Inspector” at the lower left, and right-click “div”
[image: ]
K. From the fly-out menu that appears, choose Set ID > container to apply the rules titled “container” to this div.  



	5.  Reopen the ID “container” and set the image as the background for that div.  Then delete the actual image from the div.  

	
	A. From the “CSS Styles” panel in the upper right, double-click on “#container”
B. From the “CSS Rule definition for #container” window, look under “Category” and click “Background.”
C.  On the line “Background-image,” click the “Browse” button
D. Navigate to the background image file and select it.  
E. Click “OK” to close the “CSS Rule definition for #container” window
F. In the document, click on the image and delete it.  The look of the page should not change except for the fact that you can now enter content into the “container” div on top of the image.  



	6. Inside the container div, insert a new div called “header” and create a rule for “header” that sets the height.  

	
	A. Click to set your cursor in the upper left of the “container” div
B. Choose Insert > Layout Objects > Div Tag
C. In the “Insert Div Tag” window, for “Insert,” select “At insertion point”
D. Click the “New CSS Rule” button at the bottom of the “Insert Div Tag” window
E. In the “New CSS Rule” window under “Selector Type,” choose “ID”. 
F. Under “Selector Name” type “header”
G. Click “OK”
H. In the “CSS Rule definition for #header” window, select “Box” from the 
“Category” menu on the left
I. Under “Box,” set an appropriate height to make the “header” div fill and occupy the space for the header in the design (try 125 pixels)
J. Click OK
K. Back at the “Insert Div Tag” window, click OK



	7. Immediately after the “header” div, insert a div called “sidebar1” and create an ID that floats that div to the right and sets the width (try 173 pixels) and height to align with the desired location for the link menu. 

	
	A. In the document, click inside the “header” div
B. In the Tag Inspector click the tag “div#header” to select that entire div
C. On the keyboard, click the right arrow to move the cursor to the space immediately after (beneath) the close of the “header” div
D. Choose Insert > Layout Objects > Div Tag
E. In the “Insert Div Tag” window, for “Insert,” select “At insertion point”
F. Click the “New CSS Rule” button at the bottom of the “Insert Div Tag” window
G. In the “New CSS Rule” window under “Selector Type,” choose “ID”. 
H Under “Selector Name” type “sidebar1”
I. Click “OK”
J. In the “CSS Rule definition for #sidebar1” window, select “Box” from the 
“Category” menu on the left
K. Under “Box,” set an appropriate width and height to make the “sidebar1” div fill and occupy the space for the menu in the design (try 173 W by 250 H)
L.  Beside “Float,” choose “Right.”
M.  Click OK to close the window, then click OK again to close the “Insert Div Tag” window



	8. Immediately after the “sidebar1” div, insert a div called “main_content” and create an ID for it that sets the width of the right margin to allow room for the “sidebar1” div on the right side: try 173 pixels

	
	A. In the document, click inside the “sidebar1” div
B. In the Tag Inspector click the tag “div#sidebar1” to select that entire div
C. On the keyboard, click the right arrow to move the cursor to the space immediately after (beneath) the close of the “sidebar1” div
D. Choose Insert > Layout Objects > Div Tag
E. In the “Insert Div Tag” window, for “Insert,” select “At insertion point”
F. Click the “New CSS Rule” button at the bottom of the “Insert Div Tag” window
G. In the “New CSS Rule” window under “Selector Type,” choose “ID”. 
H Under “Selector Name” type “main_content” 
I. Click “OK”
J. In the “CSS Rule definition for #main_content” window, select “Box” from the “Category” menu on the left
K. Under “Margin,” uncheck the box “Same for all”
L. Beside “Right,” enter “173 px” to set the right margin to allow room for the sidebar
M. Click OK



	9. Immediately inside the “main_content” div, insert a new div called “feature” and set the width and height to align with the feature space on the background image. 

	
	A. In the document window inside the “main_content” div, highlight and delete the words “Content for New Div Tag Goes Here”
B. Without moving the cursor, choose Insert > Layout Objects > Div Tag
C. In the “Insert Div Tag” window, for “Insert,” select “At insertion point”
D. Click the “New CSS Rule” button at the bottom of the “Insert Div Tag” window
E. In the “New CSS Rule” window under “Selector Type,” choose “ID”. 
F Under “Selector Name” type “feature” 
G. Click “OK”
H. In the “CSS Rule definition for #feature” window, select “Box” from the “Category” menu on the left
I. Set the width and height to align the div with the feature area in the design: try 465 W and 300 H
J. Set Float to “Left”
K. Click OK and then OK again to close all dialogue windows


	10. Immediately to the right (beneath in the code) of “feature” (and still inside of “main_content,” insert and style an “intro” div to occupy the space between “feature” and “sidebar1.”  Be sure to leave some margin (breathing space) on either side of this div.   

	
	A. Follow the same process as above: try Width 200, Height 250, Float Left with a left margin of 80 pixels


	11. Immediately after (beneath in the code) the “main_content” div, insert a line break and then apply a “clear float both” rule to that line break (<br>).  This will create a “ceiling” that will prevent subsequent floated divs and objects from interfering with the layout objects above it.   
A. First, be sure that Dreamweaver is displaying line breaks: on a Mac, click Dreamweaver > Preferences > Invisible Elements, and be sure that the “Line Breaks” checkbox is checked.  On a PC, click Edit > Preferences > Invisible Elements….
B. Click anywhere in the “main_content” div in the document
C. In the Tag inspector, click on the tag “<div#main_content>” to select the div
D. Hit the right arrow on the keyboard to move the cursor just outside the “main_content” div.  
E. Hit Shift+Return to insert a line break (<br>)
F. Click on the yellow line break icon in the document window to highlight it
G. Using the buttons on the upper left, switch the view from “Design” to “Split” 
[image: ]

H. In the code, check to make sure that the <br> (line break) appears immediately after the close (</div>) of the “main_content” div: 

[image: ]

I. In the “CSS Styles” panel in the upper right, click the “New CSS Rule” icon[image: ]
J. In the “New CSS Rule” window under “Selector Type,” choose “Class”
K. Under Selector Name, type “clear_float” and click OK.
L. In the “CSS Rule definition” window, choose “Box” from the left, and look for the “Clear” drop-down menu.  From it, choose “both.”  Then click OK at the bottom of the window.  
M. In the document window, click on the <br> icon
N. From the Properties Panel at the bottom, open the “Class” drop-down menu and choose “clear_float.” 
[image: ]

	
	



	12. After the clear-floated line break, add a div called “sub_content” with no rules applied to it.    This div will simple serve as a generic container keep the elements in the bottom half of the page in line.  
A. Set your cursor immediately after the line break icon
B. Choose Insert > Layout Objects > Div
C. In the Insert Div Window, type in the name “sub_content”
D. Click OK

	
13.  Inside of the div “sub_content,” insert a new div called “sub_feature” and create a set of rules to make its dimensions 465 W and 250 H, and to position the div just under “feature” (try a left margin of 30 pixels to move the div in from the left edge of the design).  Float the div to the left.  

	
	A. Follow the previous steps for inserting and styling a div.

	

	14.  Immediately to the right of the “sub_feature” div (beneath it in the code), insert a div called “bottom_right.”  Set the dimensions for “bottom_right” to be 350 W and 250 H, float left, with a left margin of 30 to create some horizontal separation from “sub_feature” 

	
	A. Follow the previous steps for inserting and styling a div.

	


	15.  To create a little vertical spacing between the “main_content” and “sub_content” divs, add a bottom margin (try 20 pixels) to whatever div in “main_content” that reaches lowest in the design: in this case the “feature” div.

	
	A. From the “CSS Styles” Panel in the upper right, double-click “#feature”
B. From the “Category” menu on the left of the “CSS Rule definition” window, choose “Box”
C. Under “Margin,” be sure the “Same for all” box is unchecked
D. Beside “Bottom,” enter 20 (the unit should be the default “px”)
E. Click OK

	

	16.  Immediately after the div “sub_content,” insert a line break and apply the “clear_float” rule to it.  

	
	A. See previous steps for applying a “clear float both” rule to a line break

	

	17.  Immediately after the clear-floated line break at the end of “sub_content,” insert div called “footer” and set the height to fill the remaining space at the bottom of the design.  Try 50 px.  

	
	A. See previous steps for inserting and styling a div tag.  


	18. Style and position some content using CSS rules and padding.  
A. In the CSS Styles Panel in the upper right, click the “New Rule” icon.  
[image: ]
B. In the “New CSS Rule” window under “Selector Type,” choose “Class”
C. Under “Selector Name,” type “tan_footer_text” and click OK
D. In the “CSS Rule definition…” window, be sure “Type” is chosen from “Category”
E. Beside “Font-size” type 0.8 and choose “em” as the unit
F. For color, choose a light brown: try #D69649.  Click OK
G. In the “CSS Styles” panel on the upper right, double-click “#footer” to open the rule.  
H.  Under “Category” choose “Box”
I. Under “Padding,” deselect the “Same for all” checkbox
J. Beside “Left,” enter “30” in front of px.  


	17.  Give the page a background color or pattern to set off the content in the foreground   

	
	A. In the CSS Styles Panel in the upper right, click the “New Rule” icon.  
B. In the “New CSS Rule” window under “Selector Type,” choose “Tag”
C. Under “Selector Name,” open the drop-down menu and select “body” and click OK
D. In the “CSS Rule definition…” window, look under “Category” and select “Background”
E. Beside “Background-color” click the color picker to open it or enter a hex code for a color: Try “#33546C”
F. Click OK
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