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Web Page from Prototype

	1. Via a link from the class web site, download the compressed .zip file containing the prototype page’s folder and then un-zip it to access the files and folders inside


	
	A. Click the link on the class web site to download the prototype’s folder   
B. Open the computer’s download folder. (On a Mac, open Finder, and look for “Downloads” in the left-hand menu)
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C. In “Downloads,” find the downloaded .zip file containing the prototype folder:
[image: ]


D. Double-click the .zip file to extract the contents. 
E. Next to the .zip file you will see a new folder appear that has been extracted from the .zip file.  




	2. Copy the contents of the extracted prototype folder into your project folder (see class web site for details)


	
	A. Double-click the newly extracted prototype folder to open it.
B. Highlight and copy (command+c) all the files and folders inside of the prototype folder (but not the entire prototype folder) 
C. Navigate to your project’s folder inside of “www” (see class web site for the project folder’s name).  
D. Delete any current contents of that folder.  (Obviously, if you have saved work in that folder, you will need to move the work elsewhere.)
E. Paste (command+v) the contents from the prototype folder into the project folder




	3. Copy any images—.jpg, .gif, .png formats, for example—that are to be used on the page into the project folder’s “assets” subfolder.  (Sometimes this subfolder for images may be titled “images.”) 


	
	Be sure to copy rather than cutting and moving them

Do not move Photoshop documents (.psd files) into the “www” folder since such documents cannot be used on web pages—web browsers can’t display them—and they are very large files that take up your limited web space.  
 



	4. If you haven’t done so already, import your “www” site information into Dreamweaver.  (See the class web site for reminders of where you can review the steps for importing site settings.)  




	5. In Dreamweaver, open the project folder and the file “index.html.”  


	
	A. From the Files Panel on the right side of the Dreamweaver workspace, click the triangle icon in front of the project folder to open the folder.  (If you don’t see a File Panel, choose “Window > Files” from the menu across the top.)
B. Double-click the “index.html” file inside the project folder.  The page should open in the large document window in the center of the workspace.  



	6. Set up Dreamweaver’s workspace for design work.   


	
	A. From the drop-down menu at the upper-left corner of the Dreamweaver window, change the default “Extract” to “Design” (if necessary)
[image: ]
B. In the upper-right of the Dreamweaver workspace, make sure the Live/Design drop-down menu is set to “Design,” and then click the “Design” button:
[image: ]




	7. Change the title of the page to a title that would make an appropriate browser bookmark 


	
	A. In the Properties Panel at the bottom, look for the “Document Title” box: 
[image: ]

B. Delete what appears in the title box and type in your own page title.  
 




	8. If desired, replace the prototype page’s existing banner—if there is one—with a banner that you’ve created for the site.  


	
	A. On the page in the document window, click on the existing banner once.  You should see a few tiny black handles appear along the bottom and the sides of the image to show it’s selected. 
B. Hit “Delete” to remove the existing banner from the page
C. Notice where the cursor is resting in the resulting blank space
D. In the Files Panel on the right, open the project’s “assets” folder if necessary. (Hint: click the triangle icon in front of the folder to toggle it open)

E. Drag your own banner file out of the Files Panel, across into the document, and drop it in the space where the old banner was located.  

(Alternatively, with the cursor resting in the location where you want the new banner to go, you can choose from the menu across the top “Insert > Image” to navigate to your banner file and insert it where the cursor sits.  



[bookmark: _GoBack]
	9. After deciding where your sections of verbal content should go on the page, paste the text into the existing sections one at a time. 


	
	A. From where you have your text written, copy the first section of text.
B. In the “index.html” page, highlight and delete the first section of the existing text. 
C. With the cursor resting in the resulting blank space, choose from the top menu “Edit > Paste Special” (or use the keyboard command “command+shift+v”).  Using “Paste Special” insures that you don’t paste in with the text unwanted formatting from the source software, which might not translate to HTML pages.  
D. In the “Paste Special” window that appears, choose the “Text with structure…” option
E. Hit “OK” 
F. Repeat for the other sections of text.  
G. If necessary, you can paste in additional sections as needed. 



	10.  Save your work by choosing from the top menu, “File > Save” or hitting the quick command “command+s”.  




	11. Revise the existing headings to introduce each section.  Make add and format new headings as necessary.  

	
	A. Highlight the first heading, delete the existing text and type or paste in your own.  Repeat with the other headings.
B. To create a new heading, type or paste in the text for the heading and highlight that text.
C.  In the Properties Panel at the bottom of the workspace, open the “Format” drop-down menu.  (Note: if you don’t see the Properties Panel, choose from the top menu “Windows > Properties”):
[image: ]

D. From the “Format” drop-down menu, choose a heading level to give your heading the appropriate weight in the page design: “heading 1” is the largest and usually appears just at the top of a page.    




	12. Insert additional images as needed.  

	
	A. In the document, click in a location where you want an inserted image to appear. 
B. In the Files Panel on the right, open the project’s “assets” folder if necessary. (Hint: click the triangle icon in front of the folder to toggle it open)
C. Drag the file containing the image out of the Files Panel, across into the document, and drop it in the space.  
D. If necessary, add (or delete) line spacing above or below the image by entering a “Return” (or deleting existing lines). 




	13.  Save your work by choosing from the top menu, “File > Save” or hitting the quick command “command+s”.  




	14. Add a link to the page  


	
	A. In the document, highlight the word or wording that you want to make into a link.  
B. In the Properties Panel at the bottom—where you’re seeing the properties of the highlight text—find the empty “Link” box:
[image: ]

C. Into that “Link” box, copy and paste the URL of the destination page for the link.  Be sure that you’re including the opening protocol “http://…” 
D. If you are linking to another page in your own site, you can choose that page from your “Files Panel”:  Click and hold on the “Point to File” icon next to the Link box: 
[image: ]
E. Still holding down your mouse, drag across the workspace and release it on the page file you’re linking to in the Files Panel.  

Dreamweaver will fill in the “Link” box with the name of the file, and any folder names necessary to create a path between the departure page and the destination page.  



	15. Change the color of the text on the page. 
(Here we dive into the world of Cascading Style Sheets!) 


	
	A. In the document, click on a small sample of the colored text.  

You are not selecting the text to make changes to it, as you might in Word or other software.  Instead, selecting the text is simply telling Dreamweaver that you want to see and edit the style-sheet rules that affect the look of this highlighted content.  

B. At the top of the Files Panel, click the “CSS Designer” tab.
[image: ]

C. At the top of the “CSS Designer” Panel, click the “Current” button. 
[image: ]

This tells Dreamweaver that you want to see only the style-sheet rules governing the appearance of the current selection (the text you’ve selected in the document window).  

D. Down in the CSS Designer Panel, you will find all the style rules governing the look of the text (since that is the “Current” kind of content selected in the document).  

The rules are organized into groups called “Selectors” (also known as “classes” or “id’s” or “tags”).

E.  Click one of the selectors in the “Selectors” pane:
[image: ]

F. With one of the selectors highlighted, you will then see the rules contained in that selector (that class, id, or tag that serves as a bundle of rules) in the nearby “Properties” pane. 
G. Scroll down into the Properties pane, if necessary, to look for a rule for text color. 

This would be simpler if we had designed the page ourselves from scratch, since we’d be more likely to remember where we had defined the rule for text color!  

Luckily, Dreamweaver give us the “COMPUTED” option, which is an automated way of looking for the rules governing the text:  

H. In the “Selectors” pane, click “COMPUTED” to see the rules that Dreamweaver has culled from the various selectors that control the look of the content you have selected in the document (in this case, the body text)

I. That rule will look like this: 
[image: ]


J. Click the color tile next to “color” to open the “set color” picker.  
K. Using the sliders and palette of the “set color” picker, choose a new color for the text if desired.  
L. Click anywhere else to close the “set color” picker.  You should see the change of text color appear in the document window.  
 



	16.  Save your work by choosing from the top menu, “File > Save” or hitting the quick command “command+s”.  




	17 Make other desired changes to the appearance of the page elements (at least those controlled by CSS) by using the same process as above.  

For example, to change the size and color of the “Heading 1”-level heading, do the following:


	
	A. In the document, click anywhere in a level-1 heading (that is, a heading formatted with “Heading 1” in the Properties Panel at the bottom of the workspace).  
B. In the “CSS Designer” Panel on the right, look in the “Selectors” pane and you’ll see the tag for “h1”
[image: ]

C. With “h1” highlighted, look in the nearby Properties Pane, where you can edit any of the rules controlling the level-1 headings: 
[image: ]

D. Notice that the size of the level-1 headings is not specified.  This means the size is based on the default settings of whatever browser is being used to view the page.  
E. To edit the size of the font, first unclick the “Show Set” checkbox at the top of the Properties Pane: 
[image: ]
Doing this will display in the Properties Pane a catalog of possible rules to set 
F. Next, at the top of the Properties Pane, click the Text icon to show only rules relating to text: 
[image: ]
G. In the Properties Pane, look down the list for the “font-size” rule: 
[image: ]

F. Click to the right of the colon and type in something like “1.5em” to see how the size looks over in the document.  Keep changing this value until you get the size you like.  

The “em” is a good unit of measure to use because it’s relative to whatever the default or standard font size is on the page.  “1em” is therefore equal to the default font size.  1.5em would be one-and-a-half times bigger than the default, etc.  





	18.  Save your work by choosing from the top menu, “File > Save” or hitting the quick command “command+s”.  




	19. Upload the project folder, or a file from it, to your web space.

	
	A. In the Files Panel, select the folder, or individual file, that you need to upload (being sure you’ve saved the file first!)

[image: ]

B. At the top of the Files Panel, click the “Put” button (Up Arrow) to upload the selected file or folder.  
[image: ]
Note that you can “Command-click” multiple files and folders to cherry-pick those you want to select, even if they’re not adjacent.  
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